Hi, I installed my York system 2 years ago July 2011 and this month I found ice on my coils, I have 3.5 ton system with new refrigerant line about 35 ft long. the system came already charged with 4.4 pound of refrigerant which support 15 ft line . the guy who installed it did not add any refrigerant for the extra 20 ft pipe. One HVAC person came to my house and added 3.11 pounds of refrigerant to the system and checked leaks and did not find any by the joints. then said he could do the deal which will cost about $700 dollar, the system still under the warranty, I thought to buy the cliplight Dry R and 937 kit super seal for my 410a system, questions is how good is cliplight and do you recommend it. or do you have any other advice. Thanks

Views: 550

Reply to This

Replies to This Discussion

   I have heard of York having some problems with leaking coils(along with almost all brands). Super seal could be used if this is the case and you have micro leaks, but this would be a band aid approach. If your system is still in warranty I would consider fixing the root problem which has yet to be determined. Sounds like the installer did not properly commission the system. Not knowing if there was a proper vacuum performed at installation, I would recommend the following work performed. Reclaim existing 410a refrigerant and replace/add refrigerant filter drier. Then perform a leak test using dry nitrogen. If there is a leak, fix or replace leaking component.  Once leak is found and fixed perform a proper vacuum to at least 500 microns. Add new 410a refrigerant and subcool or superheat depending on the metering device. Do not reuse existing refrigerant, which could be contaminated with moisture or air, or could have separated one of the mixed refrigerants. Make sure the technician verifies airflow across the evaporator coils before the final refrigerant charge. You will probably be amazed at how well your system will performed compared to before. Good luck!

all refrigerant systems leak.  all roofs leak.  all windows leak. All doors leak.   I use a lot of sealant  and clip light is better of all of them and if need be you can blow out all the "bubble gum"  with flush and dry nitrogen then put a vack  to under 500 Microns but over 200 microns so the oil in compress stays in system.   All the sealant I use works on very small holes and when hits air turns to gum so if the system is "wet"  then the whole thing seals up.  Most hacks do not use vack pumps just "flush the line" and open the valves then moisture just rots inside and     with R-410A  the oil expands with H2O  then the filter dryer fill up then beads get large then screen fills then beads get in to the meter/ cap tube, Then high presser 800 PSIG  then shuts down the compressor.    I have been to whole subdivision with plugged meters TXV's and Rev valves   

You may be focusing on the wrong culprit.  Ice forming on your coils could be caused by too little air flowing over the coil or an over-sized air conditioner.  The evaporator coils on my 3.5 ton AC frequently iced up before the outside compressor failed.  When I replaced the outside condenser and compressor with a 3 ton unit, the ice on the AC coil went away, comfort improved and my bills went down.


Home Energy Pros

Home Energy Pros was founded by the developers of Home Energy Saver Pro (sponsored by the U.S. Department of Energy,) and brought to you in partnership with Home Energy magazine.  Home Energy Pros is sponsored by the Better Buildings Residential Network.

Latest Activity

Dennis Heidner replied to Rod Fox's discussion Utility Meter Accuracy
"For Rod, second part... When I see really large electric services... my first reaction my be…"
3 hours ago
Dennis Heidner replied to Rod Fox's discussion Utility Meter Accuracy
"Rod,  I did see earlier that you had calculated the loads.  The key is even though a…"
3 hours ago
Grzegorz is now a member of Home Energy Pros
8 hours ago
Rod Fox replied to Rod Fox's discussion Utility Meter Accuracy
"Dennis, that's a ton of useful info and it will take me a bit to fully assimilate those…"
9 hours ago
Ben Haas replied to Rod Fox's discussion Utility Meter Accuracy
"Yup..... 1200 amp service to the compound.....  3 -400 amp panels, all single phase since 3…"
21 hours ago
Walter Ahlgrim replied to Rod Fox's discussion Utility Meter Accuracy
"The more I think about it if the problem cannot be the current transformers reading small loads,…"
Dennis Heidner replied to Rod Fox's discussion Utility Meter Accuracy
"Note to readers 0.5A instead of 5A for reading with A/D.... the edit to correct that didn't…"
Dennis Heidner replied to Rod Fox's discussion Utility Meter Accuracy
"Rod, I have some of the CT's that you referenced in the openenergymonitor system.  They…"

© 2015   Created by Lawrence Berkeley National Laboratory.   Powered by

Badges  |  Report an Issue  |  Terms of Service